Glean - Playback issue – Incident details

All systems operational

Playback issue

Resolved
Operational
Started about 2 months agoLasted 5 days

Affected

Glean - Frontend Application

Operational from 6:08 PM to 3:27 PM, Degraded performance from 3:27 PM to 2:21 PM, Operational from 2:21 PM to 2:21 PM

Event Uploading / Downloading

Operational from 6:08 PM to 3:27 PM, Degraded performance from 3:27 PM to 2:21 PM, Operational from 2:21 PM to 2:21 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    A fix was released at 14:00 GMT to all users.

    We advise users to perform a ‘hard refresh’ of their Glean app (CMD+SHIFT+R on macOS or CTRL+SHIFT+R on Windows).

    We will continue monitoring and provide a further update by 12:00 PM GMT on Wednesday, January 22nd, 2025.

  • Update
    Update

    Google is continuing to investigate the issue.

    We have developed a workaround and are currently testing it before releasing it to users.

    We will provide another update by 5 PM GMT on Tuesday, January 21st

  • Identified
    Identified

    We are actively working on a resolution for this incident.

    We believe the issue is affecting customers who have updated to Google Chrome version 132 or other Chromium-based browsers. Google is aware of the issue and is expected to address it in a future version of Chrome.

    In the meantime, we are implementing a temporary fix, which we anticipate will be released within the next few days.

    We'll provide another update by 12pm GMT - Tuesday 21st Jan.

  • Investigating
    Investigating

    We are aware of an issue where a small number of users are unable to playback old and new recordings. Recording audio is unaffected.